Majorlink question

Support for MBBS v10
Ragtop
Posts: 67
Joined: Sun Aug 30, 2020 11:21 pm

Majorlink question

Post by Ragtop »

Just out of curiosity, after cleanup in the morning, majorlink has to dial like 100 times before it finally connects. It's fine after that and I don't think it has the same issue when connecting during the day. It's always done this so it's not a new issue. Like I said, it's not really a problem and doesn't affect the operation. I was just wondering.

User avatar
Duckula
Posts: 356
Joined: Wed Jul 22, 2020 1:19 am

Re: Majorlink question

Post by Duckula »

That is unusual. What version are you running? What is in the audit log when it is trying to dial out?
-- Duckula

// Site admin
// Galacticomm IP owner

Ragtop
Posts: 67
Joined: Sun Aug 30, 2020 11:21 pm

Re: Majorlink question

Post by Ragtop »

It's currently MBBS V10.00, but this goes back to Worldgroup. I've noticed this for years. I never really worried about it because it eventually connects and works fine after that. Today it actually redialed 27 times before connecting. Something on my end not set up right?

03:20 11/12/23 MJRLNK: CONNECTION ATTEMPT Console
Dialed: majorlink.themajorbbs.com at 0 baud, Channel FF
03:19 11/12/23 USER LOGOFF Chan FF
User-ID: WorldLink Calling Account
03:19 11/12/23 MJRLNK: CONNECTION ATTEMPT Console
Dialed: majorlink.themajorbbs.com at 0 baud, Channel FF
03:19 11/12/23 USER LOGOFF Chan FF
User-ID: WorldLink Calling Account
03:19 11/12/23 GALTCPAT: TCP/IP RECEIVE ERROR Chan FF
tatrdt() error 10053: Software caused connection abort
03:19 11/12/23 MJRLNK: CONNECTION ATTEMPT Console
Dialed: majorlink.themajorbbs.com at 0 baud, Channel FF
03:18 11/12/23 USER LOGOFF Chan FF
User-ID: WorldLink Calling Account
03:18 11/12/23 GALTCPAT: TCP/IP RECEIVE ERROR Chan FF
tatrdt() error 10053: Software caused connection abort
03:18 11/12/23 MJRLNK: CONNECTION ATTEMPT Console
Dialed: majorlink.themajorbbs.com at 0 baud, Channel FF

User avatar
BlaZ
Posts: 81
Joined: Thu Oct 15, 2020 12:24 am
Location: Peoria, IL
Contact:

Re: Majorlink question

Post by BlaZ »

No, I know exactly what this is. The hub has the 20-minute grace period setup before it runs cleanup. At 3am EST the hub will quit answering calls while it waits for users to disconnect. As there are no users, and it's just systems linked that don't know they're supposed to disconnect, it results in the hub refusing connections for 20 minutes between 3am and 3:20am EST every morning.

Easiest fix is to change your cleanup time to a different hour. Better fix would be for the hub to change the grace period from 20 minutes to 0.

Ragtop
Posts: 67
Joined: Sun Aug 30, 2020 11:21 pm

Re: Majorlink question

Post by Ragtop »

That makes perfect sense. I figured it was something simple like that. Thanks!

User avatar
Duckula
Posts: 356
Joined: Wed Jul 22, 2020 1:19 am

Re: Majorlink question

Post by Duckula »

BlaZ is correct (of course) - I should have picked up on that from your original message.

I have changed the setting on the MajorLink hub to have a grace period of 0 minutes which should prevent this. The setting change will take effect after the next cleanup.
-- Duckula

// Site admin
// Galacticomm IP owner

Ragtop
Posts: 67
Joined: Sun Aug 30, 2020 11:21 pm

Re: Majorlink question

Post by Ragtop »

Thanks! I really wasn't that concerned with it. Was mostly tired of logging on here and no new posts. So I had to throw something out to start a conversation ;)

User avatar
Duckula
Posts: 356
Joined: Wed Jul 22, 2020 1:19 am

Re: Majorlink question

Post by Duckula »

It's good to have it resolved after all this time anyway
-- Duckula

// Site admin
// Galacticomm IP owner

User avatar
BlaZ
Posts: 81
Joined: Thu Oct 15, 2020 12:24 am
Location: Peoria, IL
Contact:

Re: Majorlink question

Post by BlaZ »

I was awake for it this morning and can confirm that this is fixed.

Ragtop
Posts: 67
Joined: Sun Aug 30, 2020 11:21 pm

Re: Majorlink question

Post by Ragtop »

Yep same here.

Post Reply